Author Topic: Cam Question  (Read 2588 times)

Offline 303ta

  • Newbie
  • *
  • Posts: 4
Cam Question
« on: July 04, 2009, 11:19:50 AM »
Cliff, This isn't a carb question,but one i hope you can help me with. I found out last week that I wiped the cam in my 400 ! I was running a Comp Cam magnum-muscle 280AH-10.Its a copy of the RAIV cam with a few changes(LSA ect.) and I was thinking of replacing it with the Crower 60243 that I see you mention on the PY forum. My question is do you think I can use this cam with the Comp Cams 995 valve springs that I have on the heads at the present time? I really do not want to change the springs that I have because I just spent 800.00 on head work. I tried researching the two companies web sites comparing the spring specs. but I'm not to clear on what I'm reading.

Thanks,Bill   

Offline Cliff Ruggles

  • Administrator
  • Qjet Hero
  • *****
  • Posts: 4784
Re: Cam Question
« Reply #1 on: July 08, 2009, 07:56:47 PM »
Bill, I'm not overly fond of those springs, but they should be fine.

We've had several sets sent here that had quite a bit more seat and open pressure than they advertise.

The inner dampner is also sharp and hard enough to dig into and eat up any shims used under the springs.

We use and prefer the Crower 68404 (1.6" installed height) or 68405's (1.7" installed height) for flat hydraulic cams with Pontiac cylinder heads.....Cliff

Offline 303ta

  • Newbie
  • *
  • Posts: 4
Re: Cam Question
« Reply #2 on: July 09, 2009, 08:49:10 AM »
Thanks Cliff, Yea I was looking at the Crower springs also, I was thinking of asking the machine shop that did the head work if I could swap out the springs myself instead of paying them to do it. But I think I know the answer to that question.